cm6 kernel issues

http://android.modaco.com/topic/328661-cm6-kernel-issues/page__view__findpost__p__1548363

some observations and comments from me, based on boot logs from my phone

<5>[0, swapper] [ 0.000000] Kernel command line: mem=128M  console=ttyMSM2,9600n8 androidboot.hardware=qcom console=ttyUSBCONSOLE0 androidboot.console=ttyUSBCONSOLE0 androidboot.localproppath=t-mobile/uk
<3>[0, swapper] [ 0.000000] Unknown boot option `androidboot.hardware=qcom': ignoring
<3>[0, swapper] [ 0.000000] Unknown boot option `androidboot.console=ttyUSBCONSOLE0': ignoring
<3>[0, swapper] [ 0.000000] Unknown boot option `androidboot.localproppath=t-mobile/uk': ignoring

i think the kernel boot options weren't working with the original t-mobile/huawei supplied roms either. these seem to be some left-over garbage from older development/testing labs, which haven't been cleansed before release.

normal users certainly wouldn't be using serial consoles or usb consoles, more so for mobile phones. these are used mostly in embedded devices.

<6>[1, swapper] [ 0.272906] ACPU running at 528000 KHz
<6>[1, swapper] [ 0.272933] Id CPU-KHz PLL DIV AHB-KHz ADIV AXI-KHz D0 D1 D2 U0 U1 U2
<6>[1, swapper] [ 0.272966]  0   19200  -1   1   19200 1   30720 -1 -1 -1  4  1  3
<6>[1, swapper] [ 0.272998]  1  120000   1   8   60000 2   61440 -1 -1 -1  4  5  6
<6>[1, swapper] [ 0.273028]  2  122880   0   2   61440 2   61440 -1  1 -1  4  5  6
<6>[1, swapper] [ 0.273058]  3  176000   2   6   88000 2   61440  2  1 -1  4  5  6
<6>[1, swapper] [ 0.273088]  4  245760   0   1   81920 3   61440  2  1  3 -1  7  6
<6>[1, swapper] [ 0.273120]  5  320000   1   3  107000 3  120000  2  1  3 -1  7  9
<6>[1, swapper] [ 0.273150]  6  352000   2   3   88000 4  120000  2  1  3 -1  7 10
<6>[1, swapper] [ 0.273181]  7  480000   1   2  120000 4  120000  4  5  6 -1 -1 16
<6>[1, swapper] [ 0.273211]  8  528000   2   2  132000 4  160000 -1  5  6 -1 -1 16
<6>[1, swapper] [ 0.273243]  9  576000   2   2  132000 4  160000 -1  5  6 -1 -1 16
<6>[1, swapper] [ 0.273273] 10  595200   2   2  132000 4  160000 -1  7  6 -1 -1 16
<6>[1, swapper] [ 0.273305] 11  614400   2   2  132000 4  160000 -1  7  8 -1 -1 16
<6>[1, swapper] [ 0.273335] 12  633600   2   2  132000 4  160000 -1  7  8 -1 -1 16
<6>[1, swapper] [ 0.273366] 13  652800   2   2  132000 4  160000 -1  7  8 -1 -1 16
<6>[1, swapper] [ 0.273396] 14  672000   2   2  132000 4  160000 -1  7  8 -1 -1 16
<6>[1, swapper] [ 0.273426] 15  691200   2   2  132000 4  160000 -1  7  8 -1 -1 16
<6>[1, swapper] [ 0.273458] 16  710400   2   2  132000 4  160000 -1  7  8 -1 -1 -1
<6>[1, swapper] [ 0.273483] 13 scaling frequencies supported.
shows the cpu clock. cpu also supports the various scaling frequencies requested by this kernel. great!

<3>[1, swapper] [ 0.273766] vendor:t-mobile,country:uk
<3>[1, swapper] [ 0.273785] USB setting is TMO
i don't think this should be set by the kernel. this is more a userspace setting.
as is the next bit.

<6>[1, swapper] [ 0.357926] cfg80211: Using static regulatory domain info
<6>[1, swapper] [ 0.357968] cfg80211: Regulatory domain: US
<6>[1, swapper] [ 0.357990]  (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
<6>[1, swapper] [ 0.358018]  (2402000 KHz - 2472000 KHz @ 40000 KHz), (600 mBi, 2700 mBm)
<6>[1, swapper] [ 0.358043]  (5170000 KHz - 5190000 KHz @ 40000 KHz), (600 mBi, 2300 mBm)
<6>[1, swapper] [ 0.358070]  (5190000 KHz - 5210000 KHz @ 40000 KHz), (600 mBi, 2300 mBm)
<6>[1, swapper] [ 0.358095]  (5210000 KHz - 5230000 KHz @ 40000 KHz), (600 mBi, 2300 mBm)
<6>[1, swapper] [ 0.358120]  (5230000 KHz - 5330000 KHz @ 40000 KHz), (600 mBi, 2300 mBm)
<6>[1, swapper] [ 0.358145]  (5735000 KHz - 5835000 KHz @ 40000 KHz), (600 mBi, 3000 mBm)
<6>[1, swapper] [ 0.358173] cfg80211: Calling CRDA for country: US
same as above.

<6>[1, swapper] [ 0.457945] smd probe
<6>[1, swapper] [ 0.457985] smd_core_init()
<6>[1, swapper] [ 0.458116] smd_core_init() done
<6>[4, events/0] [ 0.458565] smd_alloc_channel() 'DS' cid=0
<3>[1, swapper] [ 0.459233] _smem_log_init: no power log or log_idx allocated, smem_log disabled
<6>[4, events/0] [ 0.460298] smd_alloc_channel() 'DIAG' cid=1
<6>[4, events/0] [ 0.461438] smd_alloc_channel() 'RPCCALL' cid=2
<6>[4, events/0] [ 0.462358] smd_alloc_channel() 'DATA1' cid=7
<6>[4, events/0] [ 0.463461] smd_alloc_channel() 'DATA2' cid=8
<6>[4, events/0] [ 0.464556] smd_alloc_channel() 'DATA3' cid=9
<6>[4, events/0] [ 0.465650] smd_alloc_channel() 'DATA4' cid=10
<6>[4, events/0] [ 0.466716] smd_alloc_channel() 'DATA5' cid=11
<6>[4, events/0] [ 0.467663] smd_alloc_channel() 'DATA6' cid=12
<6>[4, events/0] [ 0.468575] smd_alloc_channel() 'DATA7' cid=13
<6>[4, events/0] [ 0.469706] smd_alloc_channel() 'DATA11' cid=17
<6>[4, events/0] [ 0.471493] smd_alloc_channel() 'DATA5_CNTL' cid=38
<6>[4, events/0] [ 0.472596] smd_alloc_channel() 'DATA6_CNTL' cid=39
<6>[4, events/0] [ 0.473586] smd_alloc_channel() 'DATA7_CNTL' cid=40
<6>[1, swapper] [ 0.476328] SMD Control Port Driver Initialized.
<6>[1, swapper] [ 0.478485] SMD: ch 2 CLOSED -> OPENING
<6>[1, swapper] [ 0.478610] SMD: ch 2 OPENING -> OPENED
<3>[1, swapper] [ 0.481250] Using very old AMSS modem firmware.
<3>[1, swapper] [ 0.481375] Using very old AMSS modem firmware.
i don't know, what is happening here...

<6>[1, swapper] [ 0.482580] ADSP: rs3000000a:00010000 -- 0
<3>[261, rpcrouter] [ 0.512656] rpcrouter: Server create rejected, version = 0, program = 30000012
<3>[261, rpcrouter] [ 0.512711] rpcrouter: Server create rejected, version = 0, program = 3000fe00
<3>[261, rpcrouter] [ 0.523406] rpcrouter: Server create rejected, version = 0, program = 30000066
<6>[266, krpcserversd] [ 0.524930] RPC_TIME_TOD_SET_APPS_BASES:
<6>[266, krpcserversd] [ 0.524950]  tick = 164384
<6>[266, krpcserversd] [ 0.524960]  stamp = 794911488
<4>[266, krpcserversd] [ 0.525030] drivers/rtc/hctosys.c: unable to open rtc device (rtc0)
i'm not sure, but i think we haven't selected the correct rtc drivers

<4>[1, swapper] [ 1.407706] smc91x: not found (-19).
<6>[1, swapper] [ 1.408531] rmnet0 (): not using net_device_ops yet
<6>[1, swapper] [ 1.409673] rmnet1 (): not using net_device_ops yet
<6>[1, swapper] [ 1.410958] rmnet2 (): not using net_device_ops yet
not sure, wifi???
/
<3>[1, swapper] [ 1.555413] msm_i2c msm_i2c.0: Error during data xfer (-5)
<6>[1, swapper] [ 1.558114] msm_nand: phys addr 0xa0a00000 dmac 0x7
<6>[1, swapper] [ 1.558188] allocated dma buffer at ffa2e000, dma_addr 17aee000
<6>[1, swapper] [ 1.558593] ONFI probe : CRC Check failed on ONFI Parameter data 
<6>[1, swapper] [ 1.558689] status: e00020
<6>[1, swapper] [ 1.558709] nandid: 5510baad maker ad device ba
this might potentially cause us troubles later somewhere else.
have we got the sizes correctly identified? it seems so down the later boot stages.

<6>[1, swapper] [ 1.558731] Found a supported NAND device
<6>[1, swapper] [ 1.558749] NAND Id  : 0x5510baad
<6>[1, swapper] [ 1.558764] Buswidth : 16 Bits 
<6>[1, swapper] [ 1.558779] Density  : 256 MByte
<6>[1, swapper] [ 1.558794] Pagesize : 2048 Bytes
<6>[1, swapper] [ 1.558809] Erasesize: 131072 Bytes
<6>[1, swapper] [ 1.558826] Oobsize  : 64 Bytes
<6>[1, swapper] [ 1.558841] CFG0 Init  : 0xa85408c0 
<6>[1, swapper] [ 1.558858] CFG1 Init  : 0x0004745e 
<6>[1, swapper] [ 1.558874] ECCBUFCFG  : 0x00000203 
<5>[1, swapper] [ 1.558906] Creating 6 MTD partitions on "msm_nand":
<5>[1, swapper] [ 1.558938] 0x000002600000-0x000002880000 : "boot"
<5>[1, swapper] [ 1.561813] 0x000002880000-0x000008c80000 : "system"
<5>[1, swapper] [ 1.563826] 0x000008c80000-0x00000e6c0000 : "userdata"
<5>[1, swapper] [ 1.565893] 0x00000e6c0000-0x00000fac0000 : "cache"
<5>[1, swapper] [ 1.567986] 0x00000fac0000-0x00000ff80000 : "recovery"
<5>[1, swapper] [ 1.570023] 0x00000ff80000-0x000010000000 : "misc"
<6>[1, swapper] [ 1.572903] msm_hsusb_rpc_connect: rpc connect success vers = 10001
<6>[1, swapper] [ 1.572956] msm_chg_rpc_connect: connected to rpc vers = 10001
see previous comment

<6>[1, swapper] [ 1.573163] usb_set_composition: composition set to product id = 1501
<6>[1, swapper] [ 1.573194] phy info:(2)
<6>[1, swapper] [ 1.573348] usb_probe() io=c8874000, irq=47, dma=ffa2f000(17bd0000)
<6>[1, swapper] [ 1.581601] msm_hsusb_reset_rework_installed: rework: (16777216)
<6>[1, swapper] [ 1.581644] usb_probe: reset rework is installed
<6>[1, swapper] [ 1.581954] Created the sysfs entry successfully 
<6>[1, swapper] [ 1.584379] usb_function_register: name = 'adb',  map = 3
<6>[1, swapper] [ 1.585599] usb_function_register: name = 'mass_storage',  map = 2
<6>[1, swapper] [ 1.586353] usb_function_register: name = 'diag',  map = 4
<6>[1, swapper] [ 1.588123] usb_function_register: name = 'modem',  map = 0
<3>[1, swapper] [ 1.588168] usb_function_register: unsupported function = nmea
<3>[1, swapper] [ 1.588193] gs_module_init: cannot register Function driver, ret = -22
<3>[1, swapper] [ 1.588224] usb_function_register: unsupported function = ethernet
<6>[1, swapper] [ 1.588244] cdcecm init:usb function register failed 
<3>[1, swapper] [ 1.591368] usb_start: pm_app_rpc connect failed
<6>[4, events/0] [ 2.052736] msm_chg_usb_i_is_not_available
usb driver issues

<6>[568, usb_work] [ 2.859093] msm_chg_usb_i_is_available
<3>[1, swapper] [ 2.859831] msm_i2c msm_i2c.0: Error during data xfer (-5)
<3>[1, swapper] [ 2.860014] msm_i2c msm_i2c.0: Error during data xfer (-5)
<3>[1, swapper] [ 2.860171] msm_i2c msm_i2c.0: Error during data xfer (-5)
<3>[1, swapper] [ 2.860323] msm_i2c msm_i2c.0: Error during data xfer (-5)
<3>[1, swapper] [ 2.860653] msm_i2c msm_i2c.0: Error during data xfer (-5)
<3>[1, swapper] [ 2.860823] msm_i2c msm_i2c.0: Error during data xfer (-5)
<3>[1, swapper] [ 2.860978] msm_i2c msm_i2c.0: Error during data xfer (-5)
<3>[1, swapper] [ 2.861129] msm_i2c msm_i2c.0: Error during data xfer (-5)
<3>[1, swapper] [ 2.861281] msm_i2c msm_i2c.0: Error during data xfer (-5)
<3>[1, swapper] [ 2.861428] msm_i2c msm_i2c.0: Error during data xfer (-5)
<4>[1, swapper] [ 2.861493] cpt_ts: probe of 0-000a failed with error -5
<3>[1, swapper] [ 3.164484] msm_i2c msm_i2c.0: Error during data xfer (-5)
<3>[1, swapper] [ 3.164694] msm_i2c msm_i2c.0: Error during data xfer (-5)
<3>[1, swapper] [ 3.164858] msm_i2c msm_i2c.0: Error during data xfer (-5)
<3>[1, swapper] [ 3.165013] msm_i2c msm_i2c.0: Error during data xfer (-5)
<3>[1, swapper] [ 3.165161] msm_i2c msm_i2c.0: Error during data xfer (-5)
<3>[1, swapper] [ 3.165308] msm_i2c msm_i2c.0: Error during data xfer (-5)
<3>[1, swapper] [ 3.165453] msm_i2c msm_i2c.0: Error during data xfer (-5)
<3>[1, swapper] [ 3.165601] msm_i2c msm_i2c.0: Error during data xfer (-5)
<3>[1, swapper] [ 3.165748] msm_i2c msm_i2c.0: Error during data xfer (-5)
<3>[1, swapper] [ 3.165896] msm_i2c msm_i2c.0: Error during data xfer (-5)
<4>[1, swapper] [ 3.165959] melfas-ts: probe of 0-0022 failed with error -5
<3>[1, swapper] [ 3.267109] msm_i2c msm_i2c.0: Error during data xfer (-5)
<3>[1, swapper] [ 3.267299] msm_i2c msm_i2c.0: Error during data xfer (-5)
<3>[1, swapper] [ 3.267458] msm_i2c msm_i2c.0: Error during data xfer (-5)
<3>[1, swapper] [ 3.267609] msm_i2c msm_i2c.0: Error during data xfer (-5)
<3>[1, swapper] [ 3.267758] msm_i2c msm_i2c.0: Error during data xfer (-5)
<3>[1, swapper] [ 3.267904] msm_i2c msm_i2c.0: Error during data xfer (-5)
<3>[1, swapper] [ 3.268048] msm_i2c msm_i2c.0: Error during data xfer (-5)
<3>[1, swapper] [ 3.268194] msm_i2c msm_i2c.0: Error during data xfer (-5)
<3>[1, swapper] [ 3.268339] msm_i2c msm_i2c.0: Error during data xfer (-5)
<3>[1, swapper] [ 3.268484] msm_i2c msm_i2c.0: Error during data xfer (-5)
is this due to a potential size mismatch?

<4>[1, swapper] [ 3.268521] no cypress_ts device
<4>[1, swapper] [ 3.268533]  <4>cypress-innolux-ts: probe of 0-0025 failed with error -5
<6>[1, swapper] [ 3.273229] input: gsensor as /devices/virtual/input/input1
<6>[1, swapper] [ 3.274794] gs_probe: Start gs_adixl345  in polling mode
<3>[1, swapper] [ 3.275619] msm_i2c msm_i2c.0: Error during data xfer (-5)
<3>[1, swapper] [ 3.275659] i2c_smbus_write_byte_data failed
<3>[1, swapper] [ 3.275681] i2c_smbus_write_byte_data failed
<4>[1, swapper] [ 3.275733] gs_st: probe of 0-001d failed with error -5
<3>[1, swapper] [ 3.276488] msm_i2c msm_i2c.0: Error during data xfer (-5)
<3>[1, swapper] [ 3.276533] i2c_smbus_write_byte_data failed d
<4>[1, swapper] [ 3.276584] freescale: probe of 0-001c failed with error -5
driver issues

<3>[1, swapper] [ 3.295698] mmc0: No card detect facilities available
<6>[1, swapper] [ 3.296569] mmc0: Qualcomm MSM SDCC at 0x00000000a0400000 irq 24,0 dma 8
<6>[1, swapper] [ 3.296606] mmc0: 8 bit data mode disabled
<6>[1, swapper] [ 3.296626] mmc0: 4 bit data mode enabled
<6>[1, swapper] [ 3.296643] mmc0: polling status mode disabled
<3>[1, swapper] [ 3.297231] mmc1: No card detect facilities available
<6>[1, swapper] [ 3.298456] mmc1: Qualcomm MSM SDCC at 0x00000000a0500000 irq 26,0 dma 8
<6>[1, swapper] [ 3.298494] mmc1: 8 bit data mode disabled
<6>[1, swapper] [ 3.298516] mmc1: 4 bit data mode enabled
<6>[1, swapper] [ 3.298533] mmc1: polling status mode disabled
??? card seems to be working though...

<6>[1, swapper] [ 3.311463] ALSA device list:
<6>[1, swapper] [ 3.311499]   No soundcards found.
??? sound seems to be working...

<6>[1, swapper] [ 3.321028] clock_late_init() disabled 17 unused clocks
<6>[1, swapper] [ 3.323653] input: msm-handset as /devices/virtual/input/input4
<3>[1, swapper] [ 3.324371] hs_rpc_cb_init: couldn't open rpc client with version 2 err -113
<3>[1, swapper] [ 3.324419] hs_rpc_cb_init: couldn't open rpc client with version 1 err -113
<3>[1, swapper] [ 3.324439] hs_rpc_init: failed to initialize rpc client
???

<4>[1, swapper] [ 4.079599] Warning: unable to open an initial console.
<3>[1, init] [ 4.452036] init: cannot open '/initlogo.rle'
:-)
i still get the pink t-mobile logo though... :-(

<3>[1, init] [   14.845796] init: service 'console' requires console
<3>[1, init] [   15.158059] init: cannot find '/system/bin/port-bridge', disabling 'port-bridge'
dependency issues from earlier boot stages

<3>[1, init] [   15.229979] init: cannot find '/system/bin/syncsdr', disabling 'syncsdr'
<6>[1206, rild] [   15.314119] warning: `rild' uses 32-bit capabilities (legacy support in use)
<3>[1, init] [   15.656818] init: untracked pid 1265 exited

<4>[266, krpcserversd] [   17.200006] ######### report_hs_key ###### -1
<3>[266, krpcserversd] [   17.200031] report_hs_key: No mapping for remote handset event 120
<6>[1215, mediaserver] [   17.201186] snd_set_volume 3 0 7
<4>[266, krpcserversd] [   17.201716] ######### report_hs_key ###### -1
<3>[266, krpcserversd] [   17.201749] report_hs_key: No mapping for remote handset event 156
<4>[266, krpcserversd] [   22.105078] ######### report_hs_key ###### -1
<3>[266, krpcserversd] [   22.105116] report_hs_key: No mapping for remote handset event 136
???

hopefully, this might be useful in further kernel compiles.

No comments:

Post a Comment

most popular posts